View unanswered posts | View active topics It is currently Sun Oct 20, 2019 12:04 pm



Reply to topic  [ 28 posts ]  Go to page 1, 2  Next
 Wierd Error with Server 
Author Message
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Wierd Error with Server
I'm having a wierd error with what I think is with the server. It appears to be up and running and my dyn service shows that my ip is refreshed with my hostname. When ever I try to connect via putty to it (or my father in law tries to connect with it) we only get a green box and then putty closes. It was working just fine earlier today then I had a power outage and now when I got everything back up and running, it doesn't appear to be working. :( Any suggestions? Doesn't seem to be a problem with the server or my IP/Hostname... so wierd!!!


Sat Dec 22, 2012 8:47 pm
Profile
Veteran Op

Joined: Tue Nov 28, 2006 4:04 pm
Posts: 5025
Unread post Re: Wierd Error with Server
Samek15 wrote:
I'm having a wierd error with what I think is with the server. It appears to be up and running and my dyn service shows that my ip is refreshed with my hostname. When ever I try to connect via putty to it (or my father in law tries to connect with it) we only get a green box and then putty closes. It was working just fine earlier today then I had a power outage and now when I got everything back up and running, it doesn't appear to be working. :( Any suggestions? Doesn't seem to be a problem with the server or my IP/Hostname... so wierd!!!


I would assume that your IP changed with the power outage and for some reason TWGS isn't recognizing your new IP yet. Make sure the TWGS "Stats" screen is showing the current IP.


Sat Dec 22, 2012 9:06 pm
Profile
Ambassador
User avatar

Joined: Wed Apr 20, 2011 1:19 pm
Posts: 2241
Location: Oklahoma City, OK 73170 US
Unread post Re: Wierd Error with Server
Restart the computer.
Verify DYNDNS is resolving correctly to your current external IP address.
Verify your firewall is still configured to forward the port.
Turn off windows firewall.

Can you connect to local loopback (127.0.0.1)?
Can you connect to the local machine IP (i.e. 192.168.1.10)?

_________________
Regards,
Micro

Website: http://www.microblaster.net
TWGS2.20b/TW3.34: telnet://twgs.microblaster.net:2002
TeamSpeak3: ts.microblaster.net:9987

Do not try and bend the spoon. That’s impossible.
Instead… only try to realize there is no spoon.


Sun Dec 23, 2012 1:26 am
Profile ICQ YIM WWW
Commander
User avatar

Joined: Mon Oct 29, 2001 3:00 am
Posts: 1096
Location: Tucson, AZ
Unread post Re: Wierd Error with Server
It could be that your new IP is registered with the dynamic DNS provider, but the old address is still cached somewhere, either on your ISP's DNS servers or your own computer. Open a command line and try pinging your domain name. If it says it's pinging the old IP address, try rebooting. If that doesn't help, just wait a bit for your ISP to update. (You may then have to reboot again.)

_________________
Suddenly you're Busted!


Sun Dec 23, 2012 2:50 am
Profile WWW
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Re: Wierd Error with Server
Micro wrote:
Restart the computer.
Verify DYNDNS is resolving correctly to your current external IP address.
Verify your firewall is still configured to forward the port.
Turn off windows firewall.

Can you connect to local loopback (127.0.0.1)?
Can you connect to the local machine IP (i.e. 192.168.1.10)?


I verified that my current IP address and Dyn's registered one is the same. Their software is working. My firewall is still configured to forward ports. That said, I tried both local loopback and local machine IP addresses with and without my firewall working and in each case, all I got was a green terminal box and eventually a closed session. I have not succeeded in connecting to the server at all from Putty or any external machine. It seems to me there is something wierd going on with TWGS.

Stats Screen Shows:

TWGS v2.20b Stats

Ports : Player = 23 Admin = 2003
Addresses : 192.168.1.4

Server priority : High
Connection Protocols : Player = Telnet Admin = Telnet
Active games : 0
Player sessions : Active = 0 Total = 0
Administrative sessions : Active = 0 Total = 0

Total Server Connections : 243 since 12/05/2012

Total Terminated Games : 0

Server has run for 13 Minutes


- The server address listed is not my current adress. My current IP adress is 24.176.54.110

Thanks for any and all help guys!


Sun Dec 23, 2012 8:13 pm
Profile
Veteran Op

Joined: Tue Nov 28, 2006 4:04 pm
Posts: 5025
Unread post Re: Wierd Error with Server
Samek15 wrote:
I verified that my current IP address and Dyn's registered one is the same. Their software is working. My firewall is still configured to forward ports. That said, I tried both local loopback and local machine IP addresses with and without my firewall working and in each case, all I got was a green terminal box and eventually a closed session. I have not succeeded in connecting to the server at all from Putty or any external machine. It seems to me there is something wierd going on with TWGS.

Stats Screen Shows:

TWGS v2.20b Stats

Ports : Player = 23 Admin = 2003
Addresses : 192.168.1.4
Server priority : High
Connection Protocols : Player = Telnet Admin = Telnet
Active games : 0
Player sessions : Active = 0 Total = 0
Administrative sessions : Active = 0 Total = 0

Total Server Connections : 243 since 12/05/2012

Total Terminated Games : 0

Server has run for 13 Minutes


- The server address listed is not my current adress. My current IP adress is 24.176.54.110

Thanks for any and all help guys!


The IP that I highlighted in green above is you LAN IP. TWGS isn't recognizing your WAN IP. Go to the following site to obtain your WAN IP.
http://www.whatsmyip.org/

I would say that TWGS isn't going to recognize your WAN IP unless it is outside of your router firewall. It's somewhat risky, but you can set your machine as the DMZ host outside of your router firewall and it should fix the problem.

Also I see that you have 0 active games. That may pose a problem also. I would at least activate 1 game.


Sun Dec 23, 2012 8:40 pm
Profile
Ambassador
User avatar

Joined: Fri Feb 23, 2001 3:00 am
Posts: 3891
Location: USA
Unread post Re: Wierd Error with Server
Samek15 wrote:
Micro wrote:
Restart the computer.
Verify DYNDNS is resolving correctly to your current external IP address.
Verify your firewall is still configured to forward the port.
Turn off windows firewall.

Can you connect to local loopback (127.0.0.1)?
Can you connect to the local machine IP (i.e. 192.168.1.10)?


I verified that my current IP address and Dyn's registered one is the same. Their software is working. My firewall is still configured to forward ports. That said, I tried both local loopback and local machine IP addresses with and without my firewall working and in each case, all I got was a green terminal box and eventually a closed session. I have not succeeded in connecting to the server at all from Putty or any external machine. It seems to me there is something wierd going on with TWGS.

Stats Screen Shows:

TWGS v2.20b Stats

Ports : Player = 23 Admin = 2003
Addresses : 192.168.1.4

Server priority : High
Connection Protocols : Player = Telnet Admin = Telnet
Active games : 0
Player sessions : Active = 0 Total = 0
Administrative sessions : Active = 0 Total = 0

Total Server Connections : 243 since 12/05/2012

Total Terminated Games : 0

Server has run for 13 Minutes


- The server address listed is not my current adress. My current IP adress is 24.176.54.110

Thanks for any and all help guys!



192.168.1.4 is your local network IP address.

go to http://www.whatismyip.com/ to see if your external IP address changed when you had the power outage.

I tried pinging samek15.servegame.org and it did resolve to the external IP address 24.176.54.110, and would not connect.

I'd guess that your cable modem has a dynamic IP address and you were issued a new external address with the power outage and your dns host may need to be updated with your new external address.

_________________
Image
HHT 2015 Champs: Cloud09
Big Game 2016 Champs: Draft team
2018 HHT Champs: Rock Stars


Classic Style Games Here:
telnet://Cruncherstw.no-ip.biz:2002

Web page from 1990's: https://web.archive.org/web/20170103155 ... adewar.htm
Blog with current server info: http://cruncherstw.blogspot.com
E-mail: Cruncherstw@gmail.com
FaceBook: http://www.facebook.com/CrunchersTW


Sun Dec 23, 2012 8:42 pm
Profile ICQ WWW
Commander
User avatar

Joined: Tue Oct 07, 2003 2:00 am
Posts: 1121
Location: Augusta, GA
Unread post Re: Wierd Error with Server
Can you putty to 192.168.1.4? If so, then most likely, your PC that's hosting TWGS is set to receive it's IP address via DHCP, and it's IP address on your LAN (192.168.1.4) is different than what it was before. You said the ports were still forwarded - are they forwarded to 192.168.1.4? If not, then your hosting PC was assigned a new IP by the router after the reboot.

The correct way to fix and avoid this is to statically assign your hosting PC an IP outside of the router's DHCP scope, then forward the ports to the PCs static IP. If you're unsure of what I'm saying, just assign your hosting PC an address/subnet/gateway/dns_1/dns_2 as follows:
IP: 192.168.1.250
Mask: 255.255.255.0
Gateway: 192.168.1.1
DNS 1: 8.8.8.8
DNS 2: 8.8.4.4

Then forward your TW listening port (23 by default) to 192.168.1.250.

_________________
Claim to Fame: only guy to ever crack the TW haggle algorithm, and fig/shield/hold price formula, twice.


Sun Dec 23, 2012 9:06 pm
Profile WWW
Ambassador
User avatar

Joined: Wed Apr 20, 2011 1:19 pm
Posts: 2241
Location: Oklahoma City, OK 73170 US
Unread post Re: Wierd Error with Server
Since you cannot connect to the local address of the machine, then we need to fix that before worrying about the DNS or firewall settings.

Go to server/stop server and then server/configure. On the first tab is where you set the IP address and game port. Generally setting the IP address to auto will cause it to bind to all interfaces. You can also try setting this to "Dotted" and putting in your local machine address (192.168.1.4). Note: Local loopback should no longer work when you put in the machine's IP.

Make sure the protocol is set to Telnet.

Try a different port, something might be blocking port 23.

Make sure windows firewall, and/or any 3rd party software firewall is disabled or configured to allow traffic to the game port.

Lastly, try un-installing and re-installing TWGS.

_________________
Regards,
Micro

Website: http://www.microblaster.net
TWGS2.20b/TW3.34: telnet://twgs.microblaster.net:2002
TeamSpeak3: ts.microblaster.net:9987

Do not try and bend the spoon. That’s impossible.
Instead… only try to realize there is no spoon.


Mon Dec 24, 2012 12:37 am
Profile ICQ YIM WWW
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Re: Wierd Error with Server
ElderProphet wrote:
Can you putty to 192.168.1.4? If so, then most likely, your PC that's hosting TWGS is set to receive it's IP address via DHCP, and it's IP address on your LAN (192.168.1.4) is different than what it was before. You said the ports were still forwarded - are they forwarded to 192.168.1.4? If not, then your hosting PC was assigned a new IP by the router after the reboot.

The correct way to fix and avoid this is to statically assign your hosting PC an IP outside of the router's DHCP scope, then forward the ports to the PCs static IP. If you're unsure of what I'm saying, just assign your hosting IP an address/subnet/gateway/dns_1/dns_2 as follows:
IP: 192.168.1.250
Mask: 255.255.255.0
Gateway: 192.168.1.1
DNS 1: 8.8.8.8
DNS 2: 8.8.4.4

Then forward your TW listening port (23 by default) to 192.168.1.250.


and this would be something I do in my router's settings, right? Also I will try to uninstall and reinstall my software... but I do have it registered, so can I re-register with the same keys? And how do I backup my server world/chars/etc? I'd hate to have to re-bang... oh and my 2 game servers were active when I had these issues so... wierd. 0_o

Thanks for the help guys! Merry Christmas!


Wed Dec 26, 2012 9:20 am
Profile
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Re: Wierd Error with Server
Another thing is I can connect locally so the loopback is working. I do not have a static IP through my ISP but I use a service thru dyn so that it runs software on my computer to actively update my IP with my hostname through them, so the two should be connected at all times. My current IP is being reflected on DYN's site and software as being the one they have on record currently for me.... so I guess it must be a problem with the software... *sigh*


Wed Dec 26, 2012 9:29 am
Profile
Commander

Joined: Wed Apr 14, 2004 2:00 am
Posts: 1324
Location: USA
Unread post Re: Wierd Error with Server
If your DYNDNS entry matches your current IP, then perhaps your port forwarding is set incorrectly. If your TWGS box returns a different IP address than what you have set up in your router, then anything coming in externally will never make it to your server. Does your server have a static IP?

_________________
Infecting others with a Polymorphic Virus since 1975.

Curing ignorance and terminal stupidity since 1999.

Questioning the intellectual abilities of three digit annual salary earners since 2015.


Wed Dec 26, 2012 10:30 am
Profile WWW
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Re: Wierd Error with Server
Oso wrote:
If your DYNDNS entry matches your current IP, then perhaps your port forwarding is set incorrectly. If your TWGS box returns a different IP address than what you have set up in your router, then anything coming in externally will never make it to your server. Does your server have a static IP?


i use dyn because I don't have a static ip adress... just servering TWGS on my regular PC.


Wed Dec 26, 2012 10:56 am
Profile
Commander

Joined: Wed Apr 14, 2004 2:00 am
Posts: 1324
Location: USA
Unread post Re: Wierd Error with Server
Samek15 wrote:
Oso wrote:
If your DYNDNS entry matches your current IP, then perhaps your port forwarding is set incorrectly. If your TWGS box returns a different IP address than what you have set up in your router, then anything coming in externally will never make it to your server. Does your server have a static IP?


i use dyn because I don't have a static ip adress... just servering TWGS on my regular PC.


I understand that. I was referring to whether or not your PC had a static IP address, or if your router assigns it one.
If you have port forwarding turned on and set to go to 192.168.1.x but then your PC gets the IP address of 192.168.1.y, then anything coming in will not be forwarded to your PC anymore.

_________________
Infecting others with a Polymorphic Virus since 1975.

Curing ignorance and terminal stupidity since 1999.

Questioning the intellectual abilities of three digit annual salary earners since 2015.


Wed Dec 26, 2012 11:00 am
Profile WWW
Staff Sergeant

Joined: Wed Dec 05, 2012 4:53 pm
Posts: 13
Unread post Re: Wierd Error with Server
Oso wrote:
Samek15 wrote:
Oso wrote:
If your DYNDNS entry matches your current IP, then perhaps your port forwarding is set incorrectly. If your TWGS box returns a different IP address than what you have set up in your router, then anything coming in externally will never make it to your server. Does your server have a static IP?


i use dyn because I don't have a static ip adress... just servering TWGS on my regular PC.


I understand that. I was referring to whether or not your PC had a static IP address, or if your router assigns it one.
If you have port forwarding turned on and set to go to 192.168.1.x but then your PC gets the IP address of 192.168.1.y, then anything coming in will not be forwarded to your PC anymore.


*facepalm* Oh man thats probably what happened. So that above list that Elderprophet posted, would that help assign a static ip for the port??? Sorry, I'm a bit of a newb when it comes to networking.


Wed Dec 26, 2012 11:06 am
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 28 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.