View unanswered posts | View active topics It is currently Sat Dec 14, 2019 12:23 am



Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
 EXTERN not running... 
Author Message
Staff Sergeant

Joined: Thu Mar 22, 2012 1:52 pm
Posts: 12
Unread post EXTERN not running...
I'm running TWGS 2.20b on Windows 7 64bit, not as a service. I have a single game, and EXTERN is set (as default) to run at 12:00am. However, I've had the game up for 5 days, and it has never run. I ran it manually after 3 days, because I got a warning about it, but it's never run automatically.

I'm running it as a regular user, and I have it installed under "C:\Program Files (x86)\EIS\TWGS\"

How can I fix this?

Thanks.


Thu Mar 22, 2012 2:01 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: EXTERN not running...
Make sure you have activated your game in the Command Center. When you first create a game, it will be set to inactive, and will be colored red in the game list. It will not show up in the game list for players who connect to the server with telnet or other client. But you will be able to access the game with the Command Center "play" button, or by connecting to the server on the admin port. That can sometimes be confusing, because you can enter the game and play, but if the game is not active, extern will not run. The Gold aliens will not be active either.

Make sure the first button in the game config window says "Deactivate". If it says "Activate", press it and the game will be active.

If this is not the issue, we'll take a deeper look at the situation.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Mar 22, 2012 2:20 pm
Profile WWW
Staff Sergeant

Joined: Thu Mar 22, 2012 1:52 pm
Posts: 12
Unread post Re: EXTERN not running...
It's definitely active, since it says "deactivate" and because I (and others - we're testing it before we start a real game) can log in and play, not on the admin port.

Also, there are no errors in the error logs.


Thu Mar 22, 2012 2:46 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: EXTERN not running...
Can you export the game data and send it to me so I can test it locally?

Another consideration is your local date/time format. I've seen cases in the past where an unusual locale setting for date/time formatting caused the scheduler to fail.

Also, have you shut down the server and restarted to see if extern starts to run properly?

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Mar 22, 2012 3:14 pm
Profile WWW
Staff Sergeant

Joined: Thu Mar 22, 2012 1:52 pm
Posts: 12
Unread post Re: EXTERN not running...
I did deactivate and reactivate the game, but not the server. I'll try that now, and in the mean time send you the game data.


Thu Mar 22, 2012 3:35 pm
Profile
Staff Sergeant

Joined: Thu Mar 22, 2012 1:52 pm
Posts: 12
Unread post Re: EXTERN not running...
So, I'm looking around in "C:\Program Files (x86)\EIS\TWGS\Game\" and I don't see any files named "GameA" anything (which is what the game is called, if I read the line at the bottom of the Command Center correctly); which files do you need?

Or, if they're not there, maybe there's a problem writing to that directory, since I'm running as a user? (Although, I'm not sure why that would affect the scheduling of EXTERN, since I can run it manually).


Thu Mar 22, 2012 3:44 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: EXTERN not running...
You should see a directory under Game called GameA, but that isn't what you need to do to export these files. If you deactivate your game, you can use the "Export" button, the 4th button on the game settings tab of Command Center, to save the game data to a TWA file. Then email that file.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Mar 22, 2012 4:10 pm
Profile WWW
Staff Sergeant

Joined: Thu Mar 22, 2012 1:52 pm
Posts: 12
Unread post Re: EXTERN not running...
Got it. It is all under my User/AppData/VitualStore directory (that's why I didn't see it). Email on the way.


Thu Mar 22, 2012 4:22 pm
Profile
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: EXTERN not running...
I wonder if that has anything to do with the issue.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Mar 22, 2012 5:21 pm
Profile WWW
Veteran Op
User avatar

Joined: Sat Dec 29, 2007 5:06 pm
Posts: 2059
Location: Oklahoma
Unread post Re: EXTERN not running...
Installing to C:\TWGS\ makes life much less complicated.

_________________
T0yman (Permanently Retired since 2012)
Proverbs 17:28 <-- Don't know it, most should it would stop a lot of the discussions on here.


Thu Mar 22, 2012 5:31 pm
Profile ICQ YIM WWW
Commander

Joined: Sun Feb 25, 2001 3:00 am
Posts: 1802
Location: Guam USA
Unread post Re: EXTERN not running...
richarddmorey wrote:
Got it. It is all under my User/AppData/VitualStore directory (that's why I didn't see it). Email on the way.


That is probably the problem right there ..
you have installed it in an area other then default , its vitual
and needs to be in c:\ path.

_________________
TWGS V2 Vids World on Guam Port 2002
Telnet://202.151.82.243:2002
Coconut Telegraph (ICQ)# 14340614
Founding Member -=[Team Kraaken]=- Winners of Gridwars 2010 - Ka Pla
Image

Image
Image
Undisputed Champions of 2019 HHT Just for showing up!

The Oldist , Longist Running , Orginal Registered Owner of a TWGS server :
Vids World On Guam


Thu Mar 22, 2012 6:29 pm
Profile ICQ WWW
Gameop
User avatar

Joined: Tue Nov 19, 2002 3:00 am
Posts: 1050
Location: USA
Unread post Re: EXTERN not running...
Vid Kid wrote:
richarddmorey wrote:
Got it. It is all under my User/AppData/VitualStore directory (that's why I didn't see it). Email on the way.


That is probably the problem right there ..
you have installed it in an area other then default , its vitual
and needs to be in c:\ path.


Vid or John,

Can you guys elaborate on why this is? Most software ive used does not have this specificity and require pathing to specific file directories.

Thanks

_________________
Dark Dominion TWGS
Telnet://twgs.darkworlds.org:23
ICQ#31380757, -=English 101 pwns me=-
"This one claims to have been playing since 1993 and didn't know upgrading a port would raise his alignment."


Thu Mar 22, 2012 6:56 pm
Profile ICQ
Ambassador
User avatar

Joined: Wed Nov 12, 2008 8:57 am
Posts: 3548
Location: Long Beach, CA
Unread post Re: EXTERN not running...
Kaus wrote:
Vid Kid wrote:
richarddmorey wrote:
Got it. It is all under my User/AppData/VitualStore directory (that's why I didn't see it). Email on the way.


That is probably the problem right there ..
you have installed it in an area other then default , its vitual
and needs to be in c:\ path.


Vid or John,

Can you guys elaborate on why this is? Most software ive used does not have this specificity and require pathing to specific file directories.

Thanks

Windows 7 requires you run everything as an adminstrator to work right. OR you can install everything on the root of C: (or D: whatever) using no long filenames. As far as why, that’s a MS question. :)

_________________
Helix
Do I really look like a guy with a plan? You know what I am? I'm a dog chasing cars.
Lest we forget
TTW TWGS v2 twgs.ddns.net:2002
I had to ask myself WWSGD?


Thu Mar 22, 2012 7:57 pm
Profile WWW
Site Admin
User avatar

Joined: Sun Dec 24, 2000 3:00 am
Posts: 3150
Location: USA
Unread post Re: EXTERN not running...
TWGS shouldn't require you to install into a particular directory, but since it's an unusual scenario, I just think it's one of the first things to look at.

_________________
John Pritchett
EIS
---
Help fund the TradeWars websites! If you open a hosting account with A2 Hosting, the service EIS uses for all of its sites, EIS will earn credits toward its hosting bill.


Thu Mar 22, 2012 8:05 pm
Profile WWW
Ambassador
User avatar

Joined: Wed Nov 12, 2008 8:57 am
Posts: 3548
Location: Long Beach, CA
Unread post Re: EXTERN not running...
John Pritchett wrote:
TWGS shouldn't require you to install into a particular directory, but since it's an unusual scenario, I just think it's one of the first things to look at.


From MS Answers
The Virtual Store is where Windows 7 compliant programs typically store files that need global write/access permissions such as data, .ini, and configuration files

_________________
Helix
Do I really look like a guy with a plan? You know what I am? I'm a dog chasing cars.
Lest we forget
TTW TWGS v2 twgs.ddns.net:2002
I had to ask myself WWSGD?


Thu Mar 22, 2012 8:18 pm
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 5 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware.